Critical Vulnerabilities in WordPress Plugins

Security updates have been released to address critical vulnerabilities in multiple WordPress plugins. 

The vulnerabilities affect the following plugins: 

    

  • WordPress Copymatic – AI Content Writer & Generator: Successful exploitation of the vulnerability (CVE-2024-31351) could allow an unauthenticated attacker to upload arbitrary files to a website, including backdoors, to gain access. The vulnerability has a maximum Common Vulnerability Scoring System (CVSSv3.1) score of 10 out of 10 and affects versions of the plugin prior to 1.7.
  • Pie Register – Social Sites Login (Add on): Successful exploitation of the authentication bypass vulnerability (CVE-2024-4544) could allow an unauthenticated attacker to log in as any existing user or administrator on a vulnerable website.The vulnerability has a CVSSv3.1 score of 9.8 out of 10 and affects versions of the plugin prior to 1.7.8.
  • Hash Form – Drag & Drop Form Builder: Successful exploitation of the file type validation vulnerability (CVE-2024-5084) could allow an unauthenticated attacker to upload arbitrary files to an affected site, resulting in remote code execution.  The vulnerability has a CVSSv3.1 score of 9.8 out of 10 and affects versions of the plugin prior to 1.1.1.
  • Country State City Dropdown CF7 Plugin: Successful exploitation of the SQL injection vulnerability (CVE-2024-3495) could allow an unauthenticated attacker to extract sensitive information from an affected website’s database. The vulnerability has a CVSSv3.1 score of 9.8 out of 10 and affects versions of the plugin prior to 2.7.3.
  • WPZOOM Addons for Elementor (Templates, Widgets): Successful exploitation of the vulnerability (CVE-2024-5147) could allow an unauthenticated attacker to upload and execute arbitrary files on the server, allowing the execution of any malicious PHP code in those files. The vulnerability has a CVSSv3.1 score of 9.8 out of 10 and affects versions of the plugin prior to 1.1.38.
  • Business Directory Plugin – Easy Listing Directories: Successful exploitation of the SQL injection vulnerability (CVE-2024-4443) could allow an unauthenticated attacker to extract sensitive information from an affected website’s database. The vulnerability has a CVSSv3.1 score of 9.8 out of 10 and affects versions of the plugin prior to 6.4.3.
  • UserPro Plugin: Successful exploitation of the vulnerability (CVE-2024-35700) could allow an unauthenticated attacker to escalate privileges and take full control of an affected website. The vulnerability has a CVSSv3.1 score of 9.8 out of 10 and affects versions of the plugin prior to 5.1.9.
  • Fluent Forms Contact Form Plugin: Successful exploitation of this vulnerability (CVE-2024-2771) could allow an unauthenticated to escalate privileges and take full control of an affected website. The vulnerability has a CVSSv3.1 score of 9.8 out of 10 and affects versions of the plugin prior to 5.1.17. The vulnerability is reportedly being actively exploited.
  • Web Directory Free Plugin: Successful exploitation of this SQL injection vulnerability (CVE-2024-3552) could allow an unauthenticated attacker to directly interact with an affected website’s database, which could lead to stolen information. The vulnerability has a CVSSv3.1 score of 9.3 out of 10 and affects versions of the plugin prior to 1.7.0.

Users and administrators of affected WordPress plugin versions are advised to update to the latest version immediately.

More information is available here: